YNAB Status

Welcome, YNABer!

Here’s what we know right now about any financial institutions with widespread issues (learn more about these Watchlist Institutions). If your bank lands on this page, there’s no need to hug the stress pillow. Just subscribe for updates and you’ll be the first to know!

American Express OAuth Transition
Incident Report for YNAB
Resolved
After careful consideration, we are excited to officially offer troubleshooting for American Express moving forward! Here's a recap of what we've learned:

Our import provider, Plaid, is offering a stable OAuth connection which we are happy to troubleshoot. It does not support savings accounts yet, but once it does we'll be sure to update Direct Import Watchlist Institutions: A Guide with the news. While we are excited about the improvements this OAuth integration provides, it's reliability is still subject to change so don't hesitate to reach out to Support for help.

Our other provider, MX, does support savings accounts on a non-OAuth connection. While there is likely to be some instability until their OAuth connection is released - which we will announce loud and clear once that happens - we are happy to help troubleshooting however we can.

As always our Troubleshooting Linked Accounts article has a lot to offer to get you back up and running, but when that doesn't do the trick, feel free to reach out to our Support team!
Posted Jan 30, 2024 - 20:07 UTC
Update
After monitoring the situation for a couple of months, we are excited to start troubleshooting for American Express connections!

Currently our default import provider, Plaid, has released an OAuth connection that is providing more stable imports. It does not currently support savings accounts, so we will be sure to update any developments on this in our Direct Import Watchlist Institutions: A Guide. We are excited to begin troubleshooting any other issues.



Alternatively, our other provider, MX does currently support savings accounts on a non-OAuth connection. While there is likely to be some instability until their OAuth connection is released - which we will announce loud and clear - we are happy to help troubleshooting however we can.

We will be monitoring our decision to begin troubleshooting for a week or so to ensure both connections are stable enough to support this moving forward. We will post here once we finalize our decision, so stay tuned and thanks for riding this roller coaster with us!
Posted Jan 23, 2024 - 21:41 UTC
Update
We have learned that savings accounts are not yet supported on this integration. For any savings accounts, please use our other transaction entry methods to keep your accounts up to date!
Posted Dec 19, 2023 - 18:52 UTC
Update
As we move further into the holiday season, we expect work on issues like this to slow and resolutions to take longer than usual. All teams involved will be back to business as usual in the new year, and we'll be sure to share new actionable updates then!
Posted Dec 14, 2023 - 23:39 UTC
Update
We are continuing to monitor this situation as we learn anything actionable we will let you know! In the meantime, we hope your connection is successful after removing and re-adding the connection. Thanks for hanging in their with us until we are able to troubleshoot individual connections again. We'll keep you posted!
Posted Dec 07, 2023 - 20:54 UTC
Update
We have learned that this OAuth release is region specific. If you are in Canada, there is no need to remove and re-add your connection. We will keep you in the loop here once we are able to begin troubleshooting those connections.
Posted Nov 20, 2023 - 17:47 UTC
Monitoring
We recently learned that our import providers have started the transition to support an OAuth connections on American Express. While the timeline was unexpected, we are optimistic about what this means for the future of American Express connections. We are not ready to escalate individual issues at this time, however, we have heard reports that removing and re-adding the connection has been successful. If you find you are still experiencing issues or do not see the OAuth flow, hang tight as we will be closely monitoring this transition in the coming weeks. You can subscribe here for updates as we learn more!
Posted Nov 18, 2023 - 19:04 UTC
This incident affected: Direct Import Providers (Plaid, MX).